POJ 3267为什么优先队列超时,DP就能过,难过

时间:2022-07-28
本文章向大家介绍POJ 3267为什么优先队列超时,DP就能过,难过,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

The Cow Lexicon Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 11846 Accepted: 5693 Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a’…‘z’. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said “browndcodw”. As it turns out, the intended message was “browncow” and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a’…‘z’) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L Line 2: L characters (followed by a newline, of course): the received message Lines 3…W+2: The cows’ dictionary, one word per line Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words. Sample Input

6 10 browndcodw cow milk white black brown farmer Sample Output

2 Source

USACO 2007 February Silver

就是问你删多少个字母让他成为字典里的单词构成的

这是我的垃圾的错误超时的代码,等有空再用优先队列优化一下,卡的就是三重循环,我觉得我就是被制裁了。 好好学习DP,听学长说比赛的时候DP不是我们这个水平的人做的,我也知道DP很难,各种优化,甚至现在基础的都不会,要加油。

include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include <fstream>
#include<set>
using namespace std;
string a,b[1000];
queue<string> dd;
set<string>ww;
string del(string a,string b);
int ans;
int main()
{
    int m,n;
    std::ios::sync_with_stdio(false);
    while(!dd.empty()) dd.pop();
    ww.clear();
    cin>>m>>ans;
    cin>>a;
    for(int i=0;i<m;i++)
    {
        cin>>b[i];
        if(a==b[i]){
            cout<<0<<endl;
            return 0;
        }
        string tem=del(a,b[i]);
        if(a!=tem)
        dd.push(tem);
    }
    while(!dd.empty())
    {
        string demo=dd.front();
        ans=min(ans,(int)demo.size());
        if(!ans){
            cout<<0<<endl;
            return 0;
        }
        for(int i=0;i<m;i++){
            string tem=del(demo,b[i]);
            if(demo!=tem){
                string tee=del(tem,b[i]);
                while(tee!=tem)
                {
                    tem=tee;
                    tee=del(tem,b[i]);
                }
                if(tem.size()<=ans)
                    if(ww.insert(tem).second)dd.push(tem);
            }
        }
        dd.pop();
    }
    cout<<ans<<endl;
    return 0;
}
string del(string a,string b)
{
    int j=0;
    string tem;
    string w=a;
    bool flag=0;
    for(int i=0;i<a.size();i++)
    {
        if(flag) tem.push_back(a[i]);
       else if(a[i]==b[j]) j++;
        else tem.push_back(a[i]);
        if(j==b.size())flag=1;
    }
     if(flag) return tem;
     else return w;
}

ACcode

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxl = 305;
string sentence;	//要解码的句子
string  words[601];	//字典中的句子
int w, l, d[maxl];		//d[i]表示地i个
int main()
{
        scanf("%d%d", &w, &l);
		cin>> sentence;
		for(int i = 0; i < w; i++)	cin>>words[i];
		d[l] = 0;
		for(int i = l-1; i >= 0; i--) {
			d[i] = d[i+1] + 1;
			for(int j = 0; j < w; j++) {
				int len = words[j].size();
				if(sentence[i] == words[j][0] && l-i >= len) {
					int pSentence = i, pWords = 0;
					while(pSentence < l) {
						if(words[j][pWords] == sentence[pSentence]) {
							pSentence++;	pWords++;
						}
						else	pSentence++;
						if(pWords == len) {
							d[i] = min(d[i], d[pSentence]+(pSentence-i)-len);
						}
					}
				}
			}
		}
		//for(int i = 0; i < 10; i++)	printf("%d ", d[i]);	printf("n");
		printf("%dn", d[0]);
    return 0;
}