POJ 3122 Pie

时间:2022-07-28
本文章向大家介绍POJ 3122 Pie,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Pie Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 26920 Accepted: 8150 Special Judge Description

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. Input

One line with a positive integer: the number of test cases. Then for each test case: One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends. One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies. Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3. Sample Input

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2 Sample Output

25.1327 3.1416 50.2655 Source

Northwestern Europe 2006

二分,看代码能懂!

#include<iostream>
 #include<cstdio>
#include<cmath>
#define PI  3.14159265358979
#define LL long long
#define  eps   0.0000001
using namespace std;
double ans[10010];
 int n,m,t;
bool judge(double a)
{
    int sum=0;
    for(int i=1;i<=n;++i)
    {
        sum+=(int)(ans[i]*1.0/a);
    }
    if(sum>=m+1) return 1;
    else return 0;
}
int main()
{

    //freopen("input.txt","r",stdin);
    cin>>t;
    while(t--)
    {
        cin>>n>>m;double max_=-10000000;
        for(int i=1;i<=n;++i)
        {
            int a;
            cin>>a;
            ans[i]=PI*a*a;
            max_=max(ans[i],max_);
        }
        double L=0,H=max_;double mid;
        while(fabs(H-L)>eps)
        {
             mid=(H+L)/2;
            if(judge(mid)) L=mid;
            else H=mid;
        }
        printf("%.4fn",L);
    }
}