1152 Google Recruitment

时间:2023-08-26
本文章向大家介绍1152 Google Recruitment,主要内容包括Input Specification:、Output Specification:、Sample Input 1:、Sample Output 1:、Sample Input 2:、Sample Output 2:、使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

题目:

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题目大意:给出一个l长度的字符串,求出其中第一个k位的素数

思路:

1、注意输出时不要漏了前导零

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
bool isPrime(int x){
    if(x < 2) return false;
    if(x == 2) return true;
    for(int i = 2; i < sqrt(x); i++){
        if(x % i == 0){
            return false;
        }
    }
    return true;
}
int main(){
    int l, k;
    string s;
    scanf("%d%d", &l, &k);
    cin>>s;
    for(int i = 0; i < l && i + k - 1 < l; i++){
        int sum = 0;
        for(int j = 0; j < k; j++){
            sum = sum * 10 + (s[i + j] - '0');
        }
        if(isPrime(sum)){
            for(int j = 0; j < k; j++){
                cout<<s[i + j];
            }
            cout<<endl;
            return 0;
        }else{
            continue;
        }
    }
    printf("404\n");
    return 0;
}
 

原文地址:https://www.cnblogs.com/yccy/p/17658519.html